Supported Platforms: MySQL Workbench

MySQL Workbench fully supports MySQL Server versions 5.5 and above. It may work with older server versions, but full functionality is not available then. Please note that MySQL Workbench on Linux is a Gnome application and is only formally supported on the Gnome desktop while it should run fine on other desktop environments.

MySQL Workbench 6.3 is the solution for setups using classic MySQL server versions (before MySQL 8.0), while MySQL Workbench 8.0 is the tool best optimized for use with MySQL 8.0 and higher. However, you can still use MySQL Workbench 8.0 for supported servers, including the MySQL 5.5 release series.

Important Platform Support Updates »

8.0 6.3
Operating System Architecture    
Oracle Linux / Red Hat / CentOS
Oracle Linux 7 / Red Hat Enterprise Linux 7 / CentOS 7 x86_64
Canonical
Ubuntu 18.04 LTS x86_64
Ubuntu 17.10 x86_64
Microsoft Windows Server
Windows Server 2016 x86_64  
Windows Server 2012 R2 x86_64
Microsoft Windows
Windows 10 x86_64
Windows 8 x86_64  
Apple
macOS 10.13 x86_64  
macOS 10.12 x86_64  
Various Linux
Generic Linux (tar format) x86_32, x86_64, glibc 2.12, libstdc++ 4.4
Fedora Yum Repo  

Minimum Hardware Requirements

     
Minimum Recommended
CPU 64bit x86 CPU Multi Core 64bit x86 CPU, 8 GB RAM
RAM 4 GB 8 GB or higher
Display 1024×768 1920×1200 or higher